Flash Animation
A Beginner’s Course
# Table of Contents

- About the Workshop .................................................................................................... i
- Prerequisites .............................................................................................................. i
- Workshop Objectives ............................................................................................... i
- Getting Started ....................................................................................................... 1
- Creating a Flash Document ...................................................................................... 1
- Familiarizing Flash Interface .................................................................................... 2
- Managing Workspace ................................................................................................ 3
- Setting Movie Preferences ....................................................................................... 3

## Objects and Drawings ............................................................................................. 4
- Vector vs. Bitmap ....................................................................................................... 4
- Setting Tool Options and Creating a Shape ............................................................ 5
- Reshaping an Object ................................................................................................. 5
- Transforming an Object ............................................................................................ 6

## Working with Symbols ............................................................................................ 7
- What are Symbols? ..................................................................................................... 7
- Types of Symbols ....................................................................................................... 7
- Using the Library Panel ............................................................................................. 7
- Creating Symbols ..................................................................................................... 8
- Working with Instances ........................................................................................... 9

## Working with Timelines .......................................................................................... 11
- Frame, Keyframe, Blank Keyframe .......................................................................... 11

## Creating Animation ................................................................................................ 12
- Identifying Animations in the Timeline .................................................................... 12
- Using Frames ............................................................................................................ 13
- Motion Tweening ...................................................................................................... 14
  - Using Motion Paths ................................................................................................. 16
  - Applying Ease effect ............................................................................................. 17
- Adding Nested Symbol to a Movieclip ..................................................................... 18
- Frame by Frame Animation ...................................................................................... 19
- Shape Tweening ....................................................................................................... 20

## Adding Sound .......................................................................................................... 21

## Adding Buttons ......................................................................................................... 22
- Assigning Action to a Button .................................................................................... 24

## Publishing Movie .................................................................................................... 26
About the Workshop

This introductory workshop is intended for anyone interested in learning how to create basic animation in Flash. Participants will gain familiarity with the Flash interface, learn to use the drawing tools, create animations using key frames and tweening techniques, create interactive buttons and import multimedia. Basic Action Script to create interactivity will be introduced as well.

Prerequisites

Participants must have some basic drawing and computing skills. Experience with any creative software (i.e. Photoshop, Fireworks) is a plus but not required.

Workshop Objectives

By the end of this workshop, a participant should be able to:

- Differentiate vector from bitmap images
- Become familiar with the Flash interface and tools
- Use drawing tools to create graphic content
- Create animation using frames and keyframes
- Simplify animation by using shape and motion tweening
- Create movie clips
- Create buttons that respond to user actions
- Import graphics and sounds into your project
- Reuse objects by creating symbols
- Use basic ActionScript to increase interactivity
- Publish and export a movie
Getting Started

Creating a Flash Document

Adobe Flash Professional is an authoring tool that designers and developers use to create presentations and other content that enable user interaction.

Individual pieces of content made with Flash program are called applications, even though they might only be a basic animation. You can make media-rich applications by including pictures, sound, video, and other special effects.

To create a simple FLA file:

1. From the main interface of the flash program, select Flash File (Actionscript 3.0).
Familiarizing Flash Interface

Flash Professional user interface is divided into five main parts:

- **Stage** is the white area at the center of your workspace. It is like the movie screen, where you can add objects like text, graphics, videos, and buttons.

- **Timeline** controls the timing of when elements in the movie appear on the Stage. You also use the Timeline to specify the layering order of graphics on the Stage. Graphics in higher layers appear on top of graphics in lower layers.

- **Tools panel** holds the general set of tools used for selecting objects on the stage and drawing vector graphics.

- **Property inspector** displays editable information about any selected object.

- **Library panel** is where media elements and symbols are stored and organized.
Managing Workspace

You can set how different windows will appear as you work with our animation movie. Choose from the available workspaces:

- Animator
- Classic
- Debug
- Essentials
- Designer
- Developer

The **New workspace** allows you to customize how the panels will display while working, but keep in mind that once you have deleted a workspace, Flash will not be able to retrieve it.

The **Reset** function allows you to reorganize the workspace to the default settings.

Setting Movie Preferences

Flash allows you to set the properties of your movie for each project. This way, you need not to redo the same process each time you launch the Flash Application. The preferred dimensions, frame rate, and background color can be set.

1. Click the **Properties** panel at the upper right side of the screen to view the Stage properties.
2. Click the **Edit** button in the **Property inspector** to change the stage size.
3. Click the color box and select a different color to change the color of the Stage.
4. Set the frame rate to **24 FPS**. The frame rate refers to the speed at which the animation is played at, and is measured in number of frames per second (fps).

Tip: Setting the frame rate too slow makes the animation appear to just stop and start; while setting it too fast blurs the details of the animation.

A frame rate of 24 fps is the default for new Flash documents and usually gives the best results on the web.
Objects and Drawings

After you have set everything that you need, you are now ready to add the contents to your movie. While Flash allows you to add multimedia elements to your movie, you have to take note of the file size. For images, it is suggested to use vector rather than bitmap files.

Vector vs. Bitmap

Flash uses graphic technology to display animation. Vector graphics describes an image by using lines and curves known as vectors. Vector graphics do not pixelate when you resize them. The paths of a vector graphic simply redraw no matter how much you expand or reduce it.

Raster files or bitmaps describe images using colored dots called pixels arranged in a grid. A photograph is an example of a raster graphic file. It will lose its quality as you resize and transform the image.

Activity: Pixel vs. Vector

Open 0-pixelvsvector.fla and use the zoom tool to compare the 2 images on stage.
Setting Tool Options and Creating a Shape

Flash allows you to draw objects and shapes using the Tools panel. The Tools panel is separated into sections, each containing related tools such as drawing, viewing, and selection. You can modify the object options using the Properties panel.

To draw a vector object on stage:
1. Select the Rectangle tool from the Tools panel.
2. Pick a stroke color in the Fill and Stroke color swatch in the Property inspector.
3. Pick a fill color in the Fill and Stroke color swatch in the Property inspector.
4. With the rectangle tool still selected, hold down Shift key as you drag the object on stage to create a perfect square shape.

Reshaping an Object

The Selection tool (black arrow) allows you to manipulate the object’s shape directly by dragging its border into a different contour. You can also use the Zoom tool to zoom in or out the image.

To reshape an object:
1. Select the Zoom tool in the Tools panel and then click on the object on stage to get a closer view.
2. Click the Selection tool (black arrow) in the Tools panel and then position the mouse pointer over the lower right corner of the square shape until the corner pointer is visible.
3. Hold down **Shift** key while you drag the corner pointer to the upper right corner of the square until it becomes a straight line.

4. Move the mouse pointer over the bottom edge of the triangle until the curve pointer appears, and drag it toward the upper left corner of the square.

**Transforming an Object**

The Transform tool (black arrow) allows you to modify an object by scaling, rotating, skewing, and distorting it.

To rotate an object:

1. Click the **Free transform** tool in the Tools panel, and then click the object on stage.
2. Position your mouse pointer at the lower right corner until it turns to a rotate pointer, and then drag it to rotate.

**Activity: Logo Design**

Design the attached logo using the drawing tools in Flash. Save the movie as `marine_logo.fla` and export it as `marine_logo.swf`.

**Specifications:**
- Movie size: 200 (w) x 100 (h) pixels
- Stroke color: #0098FF (blue), #00CC00 (green)
- Fill color: #03CC03
- Typeface: Berlin Sans
- Font size: 16pts.
Working with Symbols

What are Symbols?

You can turn your new artwork into a reusable asset by converting it to a symbol. A symbol is a media asset that can be reused anywhere in your document without the need to re-create it. Symbols can contain images and animations along with other types of content.

When you convert an object to a symbol, Flash automatically creates an instance, which is a copy of a symbol located on the Stage or nested inside another symbol. An instance can be different from its parent symbol in color, size, and function. Editing the symbol updates all of its instances, but applying effects to an instance of a symbol updates only that instance.

It is a good practice to convert all objects to symbol because it can reduce the file size. For example, converting a background image to a graphic symbol allows you to reuse it in other parts of your movie. Symbols can also speed SWF file playback.

Types of Symbols

- **Graphic** - is a reusable static object.
- **Button** - responds to mouse clicks, rollovers, or other actions.
- **Movie clip** - a mini movie or animation within a Flash movie. It has its own Timeline and plays independently of the main movie’s Timeline.

Using the Library Panel

Flash automatically add symbols to the library panel as soon as you create or import them. You can create folders to organize your symbols. Likewise, you can also use the common libraries to access the preset buttons and sounds.
Creating Symbols

Symbols contain all the functionality that Flash creates including animation. Consider creating an animation in a symbol especially if it has a repetitive or cyclic action.

To convert an object to a symbol:
1. Open 2-symbol.fla.
2. Click Layer 1 to select the dolphin.
3. Click Modify> Convert to Symbol or press F8 key.
4. In the Convert to Symbol dialog box, type dolphin_gr and then select Graphic under the type option.
5. Click OK.
6. Rename Layer 1 to dolphin 1.

To edit a symbol:
1. Double click dolphin_gr symbol.
2. Select the body of the dolphin and change the fill color to #CCCCCC.
3. Click Scene 1 to go back to the main timeline.
Working with Instances

Once you have created your symbols, the next step is to bring instances to your movie.

To add Instance to the stage:
1. Open the Library panel by pressing Ctrl + L.
2. Add a new layer on top of dolphin 1 and name it as dolphin 2.
3. Drag an instance of the dolphin_gr symbol on the stage.

4. Create a new layer in the timeline and name it as dark blue wave.
5. Drag an instance of the waveFoam_gr symbol from the Library panel to the middle of the stage.
6. Click Window> Info to open the Info panel.
7. Set the X value of the white wave to -110, and the Y value to 220.
8. Drag an instance of the wave_gr symbol to the stage.
9. Set the X value of the blue wave to -107, and the Y value to 222.
To edit an instance:

1. With the second \texttt{wave\_gr} instance still selected on the dark blue layer, open the \texttt{Color effect} option in the Properties panel, and then choose \texttt{Tint}.
2. Change the \texttt{Tint} amount to 100\%, and then drag the red slider to 0, green slider to 0, and blue slider to 255. This will turn the blue wave to dark blue.

3. Click dolphin 1 instance on stage.
4. Open the Transform panel, and then set the \texttt{Rotation} to -27.
5. Adjust the position of the dolphin by setting the \texttt{X} value to -23.25 and \texttt{Y} value to 252.60.
6. Click dolphin 2 instance on stage, and set the rotation value to -30.
7. Adjust the position of the dolphin by setting the \texttt{X} value to 120.20 and \texttt{Y} value to 242.80.
8. Move \texttt{dolphin 1} and \texttt{dolphin 2} layers between the light blue layer and the dark blue layer in the Timeline.

9. Press \texttt{CTRL + S} to save the changes you made.
Working with Timelines

Frame, Keyframe, Blank Keyframe

Each time you draw an object on the stage, a black circle appears on the timeline. This black circle is called a **keyframe**. It is indicating that there is an object in that particular frame. It allows you to copy the exact object to another keyframe. Usually this is used when you are animating objects.

Assuming that you want to extend the duration of an object or animation, you can do that by adding a **frame**. You will see a gray area which means Flash will display that object up to a certain number frame.

If you want to introduce a new object without affecting the previous objects displayed on the timeline, you can use a blank keyframe.

---

Tip:

- Press **F5** to add a frame (extend the duration of an object on stage)
- Press **F6** to add a keyframe (duplicate the object)
- Press **F7** to add a blank keyframe (introduce a new object)
Creating Animation

Flash provides several ways to create animation and special effects. Each method provides you with different possibilities for creating engaging animated content.

- **Motion tween**: creates animation that is continuously looping
- **Shape tween**: changes one shape to another, in a process known as morphing.
- **Frame-by-frame animation**: Flash animates an object gradually over several consecutive frames. You can control the action in every frame, which may be necessary in a complex animation.

Identifying Animations in the Timeline

Flash distinguishes tweened animation from frame-by-frame animation in the Timeline by displaying different indicators in each frame that contains content.

- A span of frames with a blue background indicates a motion tween. A black dot in the first frame of the span indicates that the tween span has a target object assigned to it. The black diamond indicates the last frame and any other property keyframe.

- A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween span still contains its property keyframe and can have a new target object applied to it.

- A black dot at the beginning keyframe with a black arrow and g background indicates a classic tween.

- A dashed line indicates that the classic tween is broken or incomplete, such as when the final keyframe is missing.
• A black dot at the beginning keyframe with a black arrow and a light green background indicates a *shape tween*.

![Shape tween example](image)

• A black dot indicates a single keyframe. Light gray *frames* after a single keyframe contain the same content with no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the span.

![Single keyframe example](image)

• A small "a" indicates that the frame is assigned a frame action with the *Actions* panel.

![Frame action example](image)

### Using Frames

1. Open *3-animation.fla*.
2. Select the ship layer and press F5 key on frame 50. The gray bar indicates that the ship instance will display until it reaches frame 50.
3. To extend further, hold down Ctrl key, place your mouse pointer over the last frame, and drag it to the frame number that you want.

![Drag frames example](image)

### Activity: Animation Techniques

Drag the following layers to frame 145: sky, ship, clouds, light blue waves, and dark blue waves
Motion Tweening

You can apply motion tween to a symbol by placing an instance in the starting keyframe and then modifying the position or transformation properties of the instance in the last keyframe of the animation.

To create a motion tween:

1. Make sure that the ship layer is unlock. Click the lock icon to unlock the layer.

2. Right click on the ship instance on stage, and select Create motion tween.
3. Hold down Shift key and drag the ship instance to the right. The line indicates the movement of the ship from point A to B.

4. Press CTRL + Enter to preview the animation.
5. Insert a new layer above the clouds layer in the Timeline and name it as logo.
6. Click File> Import> Import to Library. Locate the logo you created earlier.
7. Insert a keyframe in frame 80 by pressing F6 key.
8. Open the Library panel and drag an instance of the marine_logo to the stage.
9. Open the Info panel to change the position of the logo. Set the X value to 19 and Y value to 50.5.
10. Open the Transform panel to resize the logo to 110%.

11. Right click on the logo layer, and select Create Motion Tween.
12. Click the logo instance on stage to select it.
13. In the Properties panel, Color effect option, select Alpha, and then drag the slider to 0.

14. Insert a keyframe in frame 100, and set the Alpha effect to 100.
15. Finally, insert a keyframe in frame 120, and set the Alpha effect back to 0. This will give you a fade in, fade out effect on the logo.
16. Press CTRL + Enter to preview the animation.
**Using Motion Paths**

The motion path is a line that represents the spatial movement of the tweened instance, and it has dots that represent the target objects position along the path at frames on the timeline. Each segment of the motion path is editable.

To apply motion path to an object:
1. Hide the light blue wave layer and unlock the dolphin 1 layer.
2. Right click on the dolphin 1 and choose Create Motion Tween.
3. Add a keyframe in frame 145 by pressing F6 key.
4. Select the instance on stage, press Shift key and move to the dolphin to the right.

5. In the Transform panel, set the Rotate value to 64.7.
6. Use the Selection tool and position the curve pointer on the motion path, and drag the path a little upward (arc shape).

7. Click frame 1 of the dolphin1 layer, and click Edit> Timeline> Copy Motion.
8. Unlock the dolphin2 layer, and move the keyframe to frame 50.
9. Click **Edit** > **Timeline** > **Paste Motion**.

10. Press **CTRL + Enter** to preview the animation.

**Applying Ease effect**

When you play a motion tween, the animation moves one speed from beginning to end; this may not always provide a realistic movement. You can speed up or slow down the start or end of an animation by adjusting its easing option. When an object eases in, it starts out slow and then speeds up at the end. When it eases out, it starts out fast, and then it slows down.

To apply ease effect to your animation:

1. With the dolphin2 layer selected, type **100** in the **East** option of the Properties panel.

2. Press **CTRL + Enter** to preview the animation.
Adding Nested Symbol to a Movieclip

A movieclip lets you play an animation within your movie. Placing a symbol inside another symbol creates a nested symbol and is a great way to create a unique new symbol while preserving the individuality of the original symbols.

To add a nested symbol to a movieclip:
1. Unlock the ship layer.
2. Click frame 1 and select the ship instance on stage.
3. Press F8 key to convert the object to a symbol.
4. Type shipwithlights_mc in the name box, select Movieclip, and click OK.

5. Double click shipwithlights_mc to edit the symbol.
6. Rename layer 1 to ship and create a new layer named lights.
7. Extend the display of ship and lights layer until frame 24.
8. In frame 1 of the lights layer, drag light_gr symbol to the bow of the ship.

9. In the Color Effect option of the Properties panel, select Tint and enter #00FFCC in the color box.
10. Drag another instance of the light_gr symbol to the bow of the ship.
11. Add a keyframe in frame 12 of the lights layer.
12. Click the right instance (turquoise) and change the color to #FFFF00.
13. Click Scene 1 to go back to the main timeline.
14. Press CTRL + Enter to preview the animation.

Frame by Frame Animation

Frame-by-frame animation is the closest to the traditional animation techniques where content is created in every frame. Although it is time consuming compared to tweening, it provides the designer full control over the animation.

Please take note that a frame-by-frame animation can increase the file size more rapidly than a tweened animation.

To create a frame-by-frame animation:
1. Create a new layer above dolphin2 layer and name it as wow.
2. Click View> Guides> Show Guides.
3. Select the Pencil tool on the Tools panel, and set the properties to the ff:
   • Stroke color: #FFFFFF
   • Stroke style: dotted
4. Insert a keyframe in frame 100.
5. Draw a W in the rectangle created by the guides.
6. In frame 110, add a keyframe (F6), and draw O.
7. In frame 120, add a keyframe (F6), and draw W.
8. Press CTRL + Enter to preview the animation.
Shape Tweening

Shape tweening allows you to draw a shape at one frame, and then you change that shape or draw another shape at another frame, creating a morphing effect.

To create shape tweening:

1. Create a layer on top of clouds and name it as cloud shape tween.
2. Click frame 1 and select the oval tool from the Tools panel. Specify no stroke for the stroke color and enter #D9E0FF in the fill color box.
3. Draw an oval shape (width 110, height 40). Adjust its position by setting the X value to 448 and Y value to 33.
4. Duplicate the oval shape and set the X value to 505 and Y value to 8.5.
5. Duplicate another oval shape and set the X value to 512 and Y value to 27.
6. Select and copy the cloud shape. In frame 145 of the cloud shape tween layer, press F7 key to insert a blank keyframe.
7. Paste the cloud and adjust its position by setting the X value to -72 and Y value to 8.5.
8. Open the Transform panel and set the scale height to 78% and skew horizontal to -68.
9. Right click on the frame span on the cloud shape tween layer, and select Shape Tween.
10. Press CTRL + Enter to preview the animation.
Adding Sound

Flash allows you to import multimedia files such as audio and video to enhance your animation. All the elements are stored in the Library folder which can be reused at anytime.

To import a sound clip:
1. Insert a new layer below the dolphin 1 layer in the Timeline and name it as splash.
2. Add a keyframe in frame 60.
3. Click File>Import>Import to Library.
4. Locate splash.mp3 from the workshop folder on your desktop, and click Open.
5. Open the Library panel, and drag the sound clip to the Stage.
6. In the Sound panel, select Stream in the synch option.
7. Press CTRL + Enter to preview the animation.

Sound should synch as the dolphins touch the water.
Adding Buttons

Buttons are a special type of symbol that contains 4 frames. Each frame of a button symbol represents a different "state" for the button: Up, Over, Down, and Hit. How a button visually behaves when the mouse is rolled over it or when the user clicks on the button is determined by these four states.

You can either create a button from scratch or use the prebuilt buttons in the Library panel.

To create a new button:
1. Insert a new layer on top of light blue wave layer and name it as buttons.
2. To design your own button, click Insert> New Symbol, or press F8.
3. In the Symbol Properties dialog box, enter a name for the new button symbol and select Button in the Type option, and click OK.
4. Flash switches to symbol editing mode. The Timeline header changes to display four consecutive frames labeled Up, Over, Down, and Hit.
5. Select the second frame, labeled Over, and add a keyframe by pressing F6. The button image from the first frame appears on the Stage. Change the button image for the Over state (change bgcolor, text size).
6. Repeat step 4 for the Down frame and the Hit frame. The Hit frame defines the area of the button that responds when clicked. Make sure that the graphic for the Hit frame is a solid area large enough to encompass all the graphic elements.
of the Up, Down, and Over frames. If you do not specify a hit frame, the objects in the Up state are used as the hit frame.

7. After defining the images of the four button states, click Scene 1 to exit Symbol Edit mode.

8. Create another button to continue playing the animation.
9. Once the two buttons are created, we can now add to the scene. Create a new layer in the Timeline and name it as buttons.
10. Open the Library window drag the stop and play buttons onto the Stage.

11. Press CTRL + Enter to test the buttons.

Tip: Alternatively, you can use the prebuilt buttons in Flash. Click Window> Common Libraries> Buttons.
Assigning Action to a Button

You have created buttons in your movies that changed their appearance when users point to and click them. However, you still need to have the buttons do what they are designed to do by performing actions. To help you add this kind of interactivity to your buttons, Flash uses scripting language to interpret and execute user actions.

Learning to write Actionscript code resembles learning any new language. In language, you use grammar and vocabulary to communicate ideas. Words are fundamental units that combine to form sentences, but they only make sense when you follow a set of rules, known as syntax. In computer languages, syntax governs the order, structure, and use if words in a sentence of code. A complete sentence in AS is known as **statement**.

Punctuation is critical to a scripting language. Common syntax includes:

<table>
<thead>
<tr>
<th>Curly braces {}</th>
<th>Parenthesis ()</th>
<th>Dot (period) .</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quotation marks &quot;&quot;</td>
<td>Slashes / or //</td>
<td>Semicolon ;</td>
</tr>
</tbody>
</table>

**Actionscript 3.0**

`instanceNamehere.addEventListener(MouseEvent.CLICK, onClickStop);`

```
function onClickStop(event:MouseEvent):void {
    stop();
}
```

- **Button name**
- **Tells Flash you want it to listen for a particular event**
- **Mouse event**
- **Function name**
- **Function will return no value**
- **Action to execute**
To stop the animation:

1. Click the stop button and assign an instance name such as `stopbtn`.

2. Click the play button and assign an instance name as `playbtn`.

3. Insert a new layer in the timeline and name as `actions`.

4. Open the `Actions` panel by pressing `F9` key.

5. Type the following code below:

   ```actionscript
   stopbtn.addEventListener(MouseEvent.CLICK, onClickStop);
   function onClickStop(event:MouseEvent):void
   {
       stop();
   }
   
   playbtn.addEventListener(MouseEvent.CLICK, onClickPlay);
   function onClickPlay(event:MouseEvent):void
   {
       play();
   }
   ```

6. Press `CTRL + ENTER` keys to test the button.
Publishing Movie

FLA files refer to the raw files that you are working. These remain hidden from the visitors. When the user previews an animation created, the system generates a compressed file called **SWF** (shockwave format) which a user can use to view locally or online.

By default, the Publish command generates a Flash SWF file and an HTML document that inserts your Flash content in a browser window.

To test the movie in your local drive:
1. Press **CTRL + Enter**.

To embed flash file within a webpage:
1. Click **File**, and then choose **Publish Settings**.
2. In the Format option, select both **SWF** and **HTML**.
3. Click the folder icon to specify where to generate the SWF and HTML files.
4. Click the **Flash** tab and then make sure the **Compress Movie** tick box is checked.
5. Click **Publish** and then **OK**.