A quick-start screenshot guide to Inkscape

Created by Madison Mack and Anne Robinson in association with InPrint: A Scientific Editing Network at Washington University in St. Louis
Basic Figure Tips

Part I
Some factors to consider

- Font size – readable and consistent
- Line width – thick enough to see, but not clunky, consistent
- Simplicity – a cluttered figure with too many shapes and labels and no consistency will be meaningless and hard to comprehend
  - Goal: a figure that can quickly be understood at a glance
- Page size:
  - Look up figure dimensions in the journal to determine page size
- Color use:
  - Use sparingly
  - Be consistent
  - Be colorblind friendly...
Accommodating Colorblind Individuals

• 8% of men and 0.5% of women are red-green colorblind (NIH)
• Big effect on how colors look:

Deuteranopia: can’t see green light

http://www.colourblindawareness.org/colour-blindness/colour-blindness-experience-it/
Accommodating Colorblind Individuals

• Tips:
  • Cyan and other pale colors are basically invisible
  • Red laser pointers are basically invisible
  • Affects more than red and green: $\text{purple} = \text{red} + \text{blue}$, $\text{light green} = \text{yellow}$, etc
  • Use color intensity for contrast: $\text{light red vs. dark green}$ is visible ($\text{red vs. green}$ is not)
  • Use shapes and shadings

• Resources:
  • http://bconnelly.net/2013/10/creating-colorblind-friendly-figures/
  • http://colororacle.org/ re-colors computer screen
Accommodating Colorblind Individuals

• Tips:
  • Cyan and other pale colors are basically invisible
  • Red laser pointers are basically invisible
  • Affects more than red and green: purple = red + blue, light green = yellow, etc.
  • Use color intensity for contrast: light red vs. dark green is visible (red vs. green is not)
  • Use shapes and shadings

• Resources:
  • http://bconnelly.net/2013/10/creating-colorblind-friendly-figures/
  • http://colororacle.org/ re-colors computer screen
Accommodating Colorblind Individuals

Tips:
- Cyan and other pale colors are basically invisible
- Red laser pointers are basically invisible
- Affects more than red and green: purple = red + blue, light green = yellow, etc
- Use color intensity for contrast: light red vs. dark green is visible (red vs. green is not)
- Use shapes and shadings

Resources:
- [http://bconnelly.net/2013/10/creating-colorblind-friendly-figures/](http://bconnelly.net/2013/10/creating-colorblind-friendly-figures/)
- [http://colororacle.org/](http://colororacle.org/) re-colors computer screen
Using the Software

Part II
Getting Started

• Page size
  • Vector graphics are scalable (ie they do not “get pixelated”)
  • But page size still matters b/c **font size and line thickness are relative to page size**
  • It is easy to get lost in making figures and have no clue what size you are making things
  • It is best to **first set the page size based on your final goal** (one-column manuscript figure? Ppt slide? Other?)
How to Set the Page Size

Drag and drop to move the page size settings to a more visible location.

Tip:
Edit properties of this document (to be saved with the document) (Shift+Ctrl+D).

Custom size:
- Width: 11.76238 cm
- Height: 9.83506 cm

Background:
- Checkerboard background
- Background color:
- Display:
  - Use antialiasing

Border:
- Show page border
- Border on top of drawing
- Show border shadow
- Border color:
Getting Started

• It’s just like PowerPoint (don’t panic!)

• Ultimately, it has more flexibility and features than PowerPoint, but to get started look for tools you are already comfortable with using.

• If you don’t know what something is, hover over it and read the tool tip!!!! 😊
Inkscape, a vector graphics editor, offers a variety of tools and features, including:

- **Tool Tips:** Displayed for guidance.
- **PowerPoint-like Features:** Such as shapes, lines, text, and fill and stroke controls.
- **Group/Ungroup:** Allows for organization and layering of elements.
- **Undo:** Reverses previous actions.
- **Cut/Copy/Paste:** Enables content manipulation.
- **Rotate/Flip:** Adjusts the orientation of objects.
- **Square/Line/Shapes:** Tools for creating different types of graphical elements.
1. Cursor mode "toolbox"
2. Interact with objects
3. Formatting "windows" open

Getting Around
Palettes (specific tools grouped into categories for doing various things)
- Shape/line colors + features
- Text
- Alignment
- Snapping
- Layers
- Export

Color Palette and Tool Tips

Select cursors (icons are predictable; use tool tips)

The page to create your schema. (page size can be changed; do this first for perspective)
Getting Started

• Using Cursors
  • Every button in the “toolbox” on the left panel converts your cursor into a different “tool”.
    • Eg. to create a box, you must use the “box making” cursor
  • If you are lost, click back into standard cursor mode.
  • Use this cursor mode to do standard manipulations (move, resize, group, fill, etc).
  • If you double click on an object, you will change your cursor to that object type
Getting Started

• Useful Keyboard shortcuts
  • + and – keys zoom in/out
  • Alt + click to toggle through overlapping objects
  • Shift + click/drag to select multiple items
    • Exclusive selection (object only selected if the ENTIRE object is within the selected area)
  • Ctrl + click/resize to lock aspect ratio
  • Ctrl click + drag to lock into horizontal/perpendicular line
  • Shift + click and select color to color line instead of fill
  • F1 = standard cursor, F8 = text cursor, etc
  • Shift + | to show/hide guides
  • Lots more...learn as you want them 😊

*On Mac, “ctrl” is actually the “ctrl” key not the openApple/cmd keys
Getting Started

• A quick aside about importing
  • These programs are also super powerful for editing graphs to make them publication quality
  • Any pdf can be imported using File > Import
  • All components of the pdf (text, paths, objects) will then be editable
  • For making your own figures and combining several graphs into a single multi-panel figure, this is super powerful
Outline

- Start
  - Settings
  - Layout
  - Shortcuts

- Basic
  - Create basic objects
  - Manipulate them
  - Tools

- Advanced
  - Complex objects
  - Make things look “fancy”
  - Power tools

- Piece it Together
  - A different way of thinking

- Finishing
  - Save and Export
Outline

- Create
  - Squares, ellipses, lines, text

- Manipulate
  - Move, Scale, Rotate
  - Fill, Stroke
  - Group
  - Order
  - Flip

- Tools
  - Guides
  - Snap
  - Align
A Note About Text

• Inkscape is not great with text, so I use it sparingly
• Font size is not locked, so it resizes when you resize the box it is in
• Subscript and superscript format incorrectly when you change the font size. If you change the font size, you just have to delete and re-type the subscript and superscript letters.
• It will not wrap lines. You have to add hard enters
• You can set a default font size and font style in the Text and Font formatting window.
• Symbols: Text > Glyphs to insert symbols
  • Select font, try different scripts and range to find the symbols you want
Create an Object

1. Select cursor
2. Draw shape
3. Cursor-specific settings

- Define arc length
- Define rounded corners

Do these things with the object-specific cursor.
Example Simple Objects
- Click once to scale; twice to rotate
  - Scaling: holding down ctrl locks the aspect ratio
  - Rotating: holding down ctrl locks into standard angles (45, 90, etc)

- Standard cursor mode

- Can select color here (Shift + Click for line color)

- Location in X/Y coordinates

- Width/height/unit

- Scaling settings (what scales)

- Locks the aspect ratio (W: H ratio)

- Format stroke
  - Solid color
  - RGB color
  - Transparency

- Hue, Saturation, Lightness
Basic Manipulation

- **Grouping**
  - Can have groups of groups of groups...
  - To manipulate objects within groups, double click into the group. **You will stay in this group (and add to it) until you double click again.**
  - I group and ungroup a lot

- **Object order**
  - Can change which is on top.
  - Groups will trump order though...

- **Rotate/Flip**
  - Rotate 90 degrees
  - Flip horizontally or vertically

---

![Image of Inkscape interface showing standard cursor and tools for basic manipulation]

---

![Image of Inkscape interface with selected objects and tools for transformative actions](Fig2_final.svg - Inkscape)
Basic Tools

- Guides
  - Drag down from the top and side rulers
  - Shift + | to see/hide

- Snap
  - A bunch of options that auto-align objects when they are moved close together
  - If left on, can be annoying when you don't want
  - Useful feature at times
Basic Tools

- Alignment
  - Quick way to line up objects in various ways.
Basic Tools

- Alignment
  - Quick way to line up objects in various ways.
Outline

- Start
  - Settings
  - Layout
  - Shortcuts

- Basic
  - Create basic objects
  - Manipulate them
  - Tools

- Advanced
  - Complex objects
  - Make things look “fancy”
  - Power tools

- Piece it Together
  - A different way of thinking

- Finishing
  - Save and Export
Outline

• Create
  • Hand draw
  • Paths

• Manipulate
  • Filling with gradients
  • Crop
  • Filters

• Power Tools
  • Object to path
  • Intersection, difference, union
  • Break apart or combine paths
- 3 drawing modes
- How much to smooth line
- Connect to beginning
to make closed shape
- Hold down and drag to draw
- Release here to close and finish the path.
edit nodes of objects or paths
merges, separates, etc

control node settings: smooth, parallel, etc.

add/remove

each gray dot is a node
Simplify: automatic reduction of # of nodes  

Looks smoother + simpler
Path > Object to path will convert objects to paths
Filling with Gradients

- Click to edit gradient
- Each color in the gradient is a stop
- Imagine a light source. Be consistent for the entire figure.
- Other options
- Select gradient type
- Click to edit gradient
- Add stops
- Click + drag handles to edit gradient
To Crop:
1. Create an object to cover the part of your object that you want to REMAIN after cropping.
2. Select the marking object first, then the object you want to crop.
3. Select Object > Clip > Set
*can duplicate a shape and make a gray, blurred version to make a drop shadow
Original

Union

Intersection

Difference

Exclusion
Outline

Start
- Settings
- Layout
- Shortcuts

Basic
- Create basic objects
- Manipulate them
- Tools

Advanced
- Complex objects
- Make things look “fancy”
- Power tools

Piece it Together
- A different way of thinking

Finishing
- Save and Export
Piece it Together

- Not like drawing
- Break into simple pieces
  - Square w/ curved bottom, 2 ellipses, lines, arrow
- Use Constructive Geometry
  - Combine square + partial ellipse to get curved bottom
- Control ordering (what’s on top)
- Align
- Group

- Layers
move large, annoying objects on top to a separate layer

add a layer
Putting it all together

1. Make shapes
2. Convert to paths
3. Union of paths
4. Gradient fill
5. Black stroke
6. Duplicate path
7. Remove duplicate fill
8. Outset duplicate path
Outline

Start
- Settings
- Layout
- Shortcuts

Basic
- Create basic objects
- Manipulate them
- Tools

Advanced
- Complex objects
- Make things look “fancy”
- Power tools

Piece it Together
- A different way of thinking

Finishing
- Save and Export
Finishing

• Saving: File -> Save
  • Inkscape file type = svg

• Exporting:
  • File types:
    • pdf – scalable vector graphic, not good for Word or PPT (File -> Save a Copy As, chose file type)
    • png – good for Word and PPT, but not scalable (File -> Export png)

• Settings:
  • Background color – transparent or white?
  • DPI - resolution
Save a Copy for PDF option
What to export
resolution
filename
Resources

- **Inkscape tutorials: https://inkscape.org/en/learn/tutorials/**
  - Both “official” and “community” tutorials
  - Very useful and easy to read
- Also access the official tutorials in Inkscape: Help > Tutorials